BrepFace class

Provides strongly-typed access to brep faces. A Brep face is composed of one surface and trimming curves.
inheritence: Rhino.Runtime.CommonObjectRhino.Geometry.GeometryBaseRhino.Geometry.SurfaceRhino.Geometry.SurfaceProxyBrepFace

Namespace: Rhino.Geometry
BrepFace: references

RefitSimplySplitSurface(Curve trimCurve3d, Vector3d trimProjectionDir,Double tolerance, RefitTrimKnotMode knotAdditionMode,Int32 numInsertKnots, IEnumerable<double> Knots, RefitTrimSectionMode sectionMode,Int32 numNonTrimSpans,Boolean meetCurve,Boolean oneSided, Point3d PtActive,Boolean outputSurface,Boolean outputCurve,Int32 numSections, List<Surface> lowerSurface, List<Surface> upperSurface, List<Curve> edgeCurve,Double FitMeasurement, ref Curve trimCurveOnSurface, ref Curve splitCurve)

 
This routine accepts a 3-d trim curve (trimCrv3d). The trim curve is assumed to run from one surface edge to the opposite edge; this is referred to as a "simple" trim curve, roughly parallel to one of the srf directions (either u or v). We refer to that parameter as the "trim parameter". The routine splits the surface via the trim curve, and then refits either side ("upper" = "above the trim", and "lower" = "below the trim") as a set of untrimmed Nurbs surfaces. The idea is to retain, as much as possible, the Nurbs structure of srf, especially in the trim parameter.

Nothing found