Click or drag to resize

GH_Parser Methods

The GH_Parser type exposes the following members.

Methods
  NameDescription
Public methodStatic memberIsChapterHeaderLine
Test whether a line represents a chapter header underline. Chapter header underlines contain at least 4 consecutive equals symbols preceded or followed by any amount of white space.
Public methodStatic memberIsCommentLine
Test whether a line is a comment. Commented lines begin with double slashes (//) and are ignored during parsing.
Public methodStatic memberIsLinkLine(String)
Test whether a line represents a referenced link target. Note; this is a quick check. The link might still be invalid, use the IsLinkLine overload to include validity checks.
Public methodStatic memberIsLinkLine(String, String, String, String)
Test whether a line represents a referenced link target.
Public methodStatic memberIsListLine
Test whether a line contains a list item.
Public methodStatic memberIsParagraphHeaderLine
Test whether a line represents a paragraph header underline. Paragraph header underlines contain at least 4 consecutive dashes preceded or followed by any amount of white space.
Public methodStatic memberIsQuoteLine
Test whether a line is a block quote line. Block quotes start with a larger than symbol.
Public methodStatic memberStringToFragment
Parse a block of text and return it as an interpreted IGH_Fragment.
Top
See Also