Click or drag to resize

GH_LinkedParamAttributes Class

These Attributes are assigned to parameters that are part of a GH_Component.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_AttributesIGH_Param
    Grasshopper.Kernel.AttributesGH_LinkedParamAttributes

Namespace:  Grasshopper.Kernel.Attributes
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_LinkedParamAttributes : GH_Attributes<IGH_Param>

The GH_LinkedParamAttributes type exposes the following members.

Constructors
  NameDescription
Public methodGH_LinkedParamAttributes
Initializes a new instance of the GH_LinkedParamAttributes class
Top
Properties
  NameDescription
Public propertyHasInputGrip (Overrides GH_AttributesTHasInputGrip.)
Public propertyHasOutputGrip (Overrides GH_AttributesTHasOutputGrip.)
Top
Methods
  NameDescription
Protected methodLayout (Overrides GH_AttributesTLayout.)
Protected methodRender (Overrides GH_AttributesTRender(GH_Canvas, Graphics, GH_CanvasChannel).)
Public methodSetupTooltip (Overrides GH_AttributesTSetupTooltip(PointF, GH_TooltipDisplayEventArgs).)
Top
See Also