Click or drag to resize

GH_ComponentGH_OutputParamManager Class

This class is used during Component construction to add output parameters.
Inheritance Hierarchy
SystemObject
  GH_ParamManager
    Grasshopper.KernelGH_ComponentGH_OutputParamManager

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
protected class GH_OutputParamManager : GH_ParamManager

The GH_ComponentGH_OutputParamManager type exposes the following members.

Properties
  NameDescription
Public propertyParam
Gets the output parameter at the given index.
(Overrides GH_ParamManager.Param.)
Public propertyParamCount
Returns the number of output parameters already part of this component.
(Overrides GH_ParamManager.ParamCount.)
Top
Methods
  NameDescription
Public methodAddArcParameter
Add a 3D Arc parameter to the output list of this component.
Public methodAddBooleanParameter
Add a Boolean parameter to the output list of this component.
Public methodAddBoxParameter
Add a 3D Box parameter to the output list of this component.
Public methodAddBrepParameter
Add a Brep parameter to the output list of this component. Brep parameters can handle both trimmed and untrimmed single or multi-faced Breps.
Public methodAddCircleParameter
Add a 3D Circle parameter to the output list of this component.
Public methodAddColourParameter
Add a ARGB Colour parameter to the output list of this component.
Public methodAddComplexNumberParameter
Add a Complex Number parameter to the output list of this component.
Public methodAddCultureParameter
Add a Culture parameter to the output list of this component.
Public methodAddCurveParameter
Add a Curve parameter to the output list of this component. Curve parameters can handle all curve types (Lines, Polylines, Circles, Arcs, NurbsCurves etc.)
Public methodAddFieldParameter
Add a Field parameter to the output list of this component.
Public methodAddGenericParameter
Add a Generic parameter to the output list of this component. Generic parameters can handle all types of data.
Public methodAddGeometryParameter
Add a Geometry parameter to the output list of this component. Geometry parameters can handle all types that represent actual shapes.
Public methodAddGroupParameter
Add a Transform Group parameter to the output list of this component. Groups are collections of geometry that are transformed as one, they are not the same as Rhino groups.
Public methodAddIntegerParameter
Add a Integer parameter to the output list of this component.
Public methodAddInterval2DParameter
Add a Interval2D (i.e. uv domain) parameter to the output list of this component.
Public methodAddIntervalParameter
Add a Interval (i.e. numeric domain) parameter to the output list of this component.
Public methodAddLineParameter
Add a 3D Line parameter to the output list of this component.
Public methodAddMatrixParameter
Add a Matrix parameter to the output list of this component.
Public methodAddMeshFaceParameter
Add a topological MeshFace parameter to the output list of this component.
Public methodAddMeshParameter
Add a Mesh parameter to the output list of this component.
Public methodAddNumberParameter
Add a floating point Number parameter to the output list of this component.
Public methodAddParameter(IGH_Param)
Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public methodAddParameter(IGH_Param, String, String, String, GH_ParamAccess)
Generic parameter addition. If you cannot use one of the utility methods provided by this class, you can register a customized parameter using this method.
Public methodAddPathParameter
Add a Data Path parameter to the output list of this component.
Public methodAddPlaneParameter
Add a 3D Plane parameter to the output list of this component.
Public methodAddPointParameter
Add a 3D Point parameter to the output list of this component.
Public methodAddRectangleParameter
Add a 3D Rectangle parameter to the output list of this component.
Public methodAddSubDParameter
Add a Sub-D parameter to the output list of this component.
Public methodAddSurfaceParameter
Add a Surface parameter to the output list of this component. Surface parameters can handle both trimmed and untrimmed single-faced Breps.
Public methodAddTextParameter
Add a Text parameter to the output list of this component.
Public methodAddTimeParameter
Add a Time parameter to the output list of this component.
Public methodAddTransformParameter
Add a Transformation parameter to the output list of this component.
Public methodAddVectorParameter
Add a 3D Vector parameter to the output list of this component.
Public methodHideParameter
Hide a specific output parameter. If the parameter at the given index implement IGH_PreviewObject then the Hidden flag will be set to True. Otherwise, nothing will happen.
(Overrides GH_ParamManager.HideParameter(Int32).)
Public methodRegister_2DIntervalParam(String, String, String)
Register a new two-dimensional OnInterval parameter
Public methodRegister_2DIntervalParam(String, String, String, GH_ParamAccess)
Register a new two-dimensional OnInterval parameter
Public methodRegister_ArcParam(String, String, String)
Register a new 3D arc parameter
Public methodRegister_ArcParam(String, String, String, GH_ParamAccess)
Register a new 3D arc parameter
Public methodRegister_BooleanParam(String, String, String)
Register a new Boolean primitive parameter
Public methodRegister_BooleanParam(String, String, String, GH_ParamAccess)
Register a new Boolean primitive parameter
Public methodRegister_BoxParam(String, String, String)
Register a new 3D box parameter
Public methodRegister_BoxParam(String, String, String, GH_ParamAccess)
Register a new 3D box parameter
Public methodRegister_BRepParam(String, String, String)
Register a new 3D Brep parameter
Public methodRegister_BRepParam(String, String, String, GH_ParamAccess)
Register a new 3D Brep parameter
Public methodRegister_CircleParam(String, String, String)
Register a new 3D circle parameter
Public methodRegister_CircleParam(String, String, String, GH_ParamAccess)
Register a new 3D circle parameter
Public methodRegister_ColourParam(String, String, String)
Register a new Colour primitive parameter
Public methodRegister_ColourParam(String, String, String, GH_ParamAccess)
Register a new Colour primitive parameter
Public methodRegister_ComplexParam(String, String, String)
Register a new Complex primitive parameter
Public methodRegister_ComplexParam(String, String, String, GH_ParamAccess)
Register a new Complex primitive parameter
Public methodRegister_CurveParam(String, String, String)
Register a new 3D curve parameter
Public methodRegister_CurveParam(String, String, String, GH_ParamAccess)
Register a new 3D curve parameter
Public methodRegister_DoubleParam(String, String, String)
Register a new Double primitive parameter
Public methodRegister_DoubleParam(String, String, String, GH_ParamAccess)
Register a new Double primitive parameter
Public methodRegister_FieldParam(String, String, String)
Register a new field parameter
Public methodRegister_FieldParam(String, String, String, GH_ParamAccess)
Register a new field parameter
Public methodRegister_GenericParam(String, String, String)
Register a new Generic (Object) parameter
Public methodRegister_GenericParam(String, String, String, GH_ParamAccess)
Register a new Generic (Object) parameter
Public methodRegister_GeometryParam(String, String, String)
Register a new 3D geometry parameter
Public methodRegister_GeometryParam(String, String, String, GH_ParamAccess)
Register a new 3D geometry parameter
Public methodRegister_GroupParam(String, String, String)
Register a new geometric group parameter
Public methodRegister_GroupParam(String, String, String, GH_ParamAccess)
Register a new geometric group parameter
Public methodRegister_IntegerParam(String, String, String)
Register a new Integer primitive parameter
Public methodRegister_IntegerParam(String, String, String, GH_ParamAccess)
Register a new Integer primitive parameter
Public methodRegister_IntervalParam(String, String, String)
Register a new Interval parameter
Public methodRegister_IntervalParam(String, String, String, GH_ParamAccess)
Register a new Interval parameter
Public methodRegister_LineParam(String, String, String)
Register a new 3D line parameter
Public methodRegister_LineParam(String, String, String, GH_ParamAccess)
Register a new 3D line parameter
Public methodRegister_MatrixParam(String, String, String)
Register a new matrix parameter
Public methodRegister_MatrixParam(String, String, String, GH_ParamAccess)
Register a new matrix parameter
Public methodRegister_MeshFaceParam(String, String, String)
Register a new 3D Mesh face parameter
Public methodRegister_MeshFaceParam(String, String, String, GH_ParamAccess)
Register a new 3D Mesh face parameter
Public methodRegister_MeshParam(String, String, String)
Register a new 3D Mesh parameter
Public methodRegister_MeshParam(String, String, String, GH_ParamAccess)
Register a new 3D Mesh parameter
Public methodRegister_PathParam(String, String, String)
Register a new Data Structure path parameter
Public methodRegister_PathParam(String, String, String, GH_ParamAccess)
Register a new Data Structure path parameter
Public methodRegister_PlaneParam(String, String, String)
Register a new 3D plane parameter
Public methodRegister_PlaneParam(String, String, String, GH_ParamAccess)
Register a new 3D plane parameter
Public methodRegister_PointParam(String, String, String)
Register a new 3D point parameter
Public methodRegister_PointParam(String, String, String, GH_ParamAccess)
Register a new 3D point parameter
Public methodRegister_RectangleParam(String, String, String)
Register a new 3D rectangle parameter
Public methodRegister_RectangleParam(String, String, String, GH_ParamAccess)
Register a new 3D rectangle parameter
Public methodRegister_StringParam(String, String, String)
Register a new String primitive parameter
Public methodRegister_StringParam(String, String, String, GH_ParamAccess)
Register a new String primitive parameter
Public methodRegister_SurfaceParam(String, String, String)
Register a new 3D surface parameter
Public methodRegister_SurfaceParam(String, String, String, GH_ParamAccess)
Register a new 3D surface parameter
Public methodRegister_TransformParam(String, String, String)
Register a new Transform parameter
Public methodRegister_TransformParam(String, String, String, GH_ParamAccess)
Register a new Transform parameter
Public methodRegister_VectorParam(String, String, String)
Register a new 3D vector parameter
Public methodRegister_VectorParam(String, String, String, GH_ParamAccess)
Register a new 3D vector parameter
Public methodRegisterParam(IGH_Param)
Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public methodRegisterParam(IGH_Param, GH_ParamAccess)
Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public methodRegisterParam(IGH_Param, String, String, String)
Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Public methodRegisterParam(IGH_Param, String, String, String, GH_ParamAccess)
Generic parameter registration. This class provides methods to register standard parameters, but if you have a special type you're in charge of setting it all up yourself.
Top
See Also