Description:

Returns True if some portion of a world coordinate bounding box is potentially visible in the viewing frustum.

Syntax:
public bool IsVisible(
BoundingBox bbox
)
Parameters:
  • bbox
  • Type: BoundingBox
  • A bounding box that is tested for visibility.
Returns:
Type: bool
True if the box is potentially visible; otherwise false.
Available since:
5.0

Description:

Determines if a world coordinate point is visible in the viewing frustum.

Syntax:
public bool IsVisible(
Point3d point
)
Parameters:
  • point
  • Type: Point3d
  • A point that is tested for visibility.
Returns:
Type: bool
True if the point is visible; otherwise false.
Available since:
5.0

IsVisible method

Class:  Rhino.Display.RhinoViewport

Nothing found