Description:

Rotates about the specified axis. A positive rotation angle results in a counter-clockwise rotation about the axis (right hand rule).

Syntax:
public bool Rotate(
double angleRadians,
Vector3d rotationAxis,
Point3d rotationCenter
)
Parameters:
  • angleRadians
  • Type: double
  • angle of rotation in radians.
  • rotationAxis
  • Type: Vector3d
  • direction of the axis of rotation.
  • rotationCenter
  • Type: Point3d
  • point on the axis of rotation.
Returns:
Type: bool
True if geometry successfully rotated.
Available since:
5.0

Nothing found