Click or drag to resize

GH_RhinoScriptInterfaceIsEditorVisible Method

Returns the visible state of the Grasshopper Main window.

Namespace:  Grasshopper.Plugin
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool IsEditorVisible()

Return Value

Type: Boolean
True if the Main Grasshopper Window has been loaded and is visible.
Examples
VBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH 
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call Rhino.Print("Grasshopper Editor Visible: " & GH.IsEditorVisible())
  Set GH = Nothing
End Sub
See Also