Click or drag to resize

GH_RhinoScriptInterfaceOpenDocument Method

Open a Grasshopper document. The editor will be loaded if necessary, but it will not be automatically shown.

Namespace:  Grasshopper.Plugin
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool OpenDocument(
	string filename
)

Parameters

filename
Type: SystemString
Path of file to open (must be a *.gh or *.ghx extension).

Return Value

Type: Boolean
True on success, false on failure.
Examples
VBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH 
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.OpenDocument("C:\ExampleFile.ghx")
  Set GH = Nothing
End Sub
See Also