Click or drag to resize

GH_Curve Methods

The GH_Curve type exposes the following members.

Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches
Clears all volatile caches for this instance. The boundingbox is cleared, and if the curve is referenced, the local instance of the curve is erased.
(Overrides GH_GeometricGooTClearCaches.)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateCurve
Create a duplicate of this curve.
Public methodDuplicateGeometry
Create a duplicate of this curve.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodEmitProxy
Returns a proxy that represents this curve. Do not call this function unless you're
(Overrides GH_GeometricGooTEmitProxy.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc)
If the curve is referenced and not yet loaded, attempts to load the curve.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMakeDeformable
Converts the local geometry into deformable nurbs curve geometry. This method will not destroy Reference data.
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString
Format the curve using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
See Also