Click or drag to resize

GH_Curve Class

Represents a 3D spline curve.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooCurve
    Grasshopper.Kernel.TypesGH_GeometricGooCurve
      Grasshopper.Kernel.TypesGH_Curve

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Curve : GH_GeometricGoo<Curve>, 
	IGH_BakeAwareData, IGH_PreviewData

The GH_Curve type exposes the following members.

Constructors
  NameDescription
Public methodGH_Curve
Default constructor, creates an invalid curve.
Public methodGH_Curve(Curve)
Create a duplicate of an existing curve.
Public methodGH_Curve(GH_Curve)
Create a duplicate of another GH_Curve. This constructor also copies reference data.
Public methodGH_Curve(Guid)
Create a new referenced curve that references a Rhino curve object with the specified ID.
Public methodGH_Curve(Guid, Int32)
Create a new references edge curve that references an edge index in a Rhino Brep object.
Top
Properties
  NameDescription
Public propertyBoundingbox (Overrides GH_GeometricGooTBoundingbox.)
Public propertyClippingBox
Public propertyIsGeometryLoaded
Gets the load state of this curve object. The curve is considered to be loaded when the local OnCurve instance is not null.
(Overrides GH_GeometricGooTIsGeometryLoaded.)
Public propertyIsValid
Gets the validity of this curve. If the curve is referenced but cannot be loaded, the curve is not valid.
(Overrides GH_GeometricGooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyReferenceEdge
Gets or sets the edge index for a referenced curve. If the index >= 0 then an edge reference is implied.
Public propertyReferenceID (Overrides GH_GeometricGooTReferenceID.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Public propertyValue (Overrides GH_GeometricGooTValue.)
Top
Methods
  NameDescription
Public methodBakeGeometry
Public methodCastFrom
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastFrom(Object).)
Public methodCastToT(T)
Local to Remote caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GeometricGooTCastToQ(Q).)
Public methodClearCaches
Clears all volatile caches for this instance. The boundingbox is cleared, and if the curve is referenced, the local instance of the curve is erased.
(Overrides GH_GeometricGooTClearCaches.)
Public methodDrawViewportMeshes
Public methodDrawViewportWires
Public methodDuplicate (Overrides GH_GeometricGooTDuplicate.)
Public methodDuplicateCurve
Create a duplicate of this curve.
Public methodDuplicateGeometry
Create a duplicate of this curve.
(Overrides GH_GeometricGooTDuplicateGeometry.)
Public methodEmitProxy
Returns a proxy that represents this curve. Do not call this function unless you're
(Overrides GH_GeometricGooTEmitProxy.)
Public methodGetBoundingBox (Overrides GH_GeometricGooTGetBoundingBox(Transform).)
Public methodLoadGeometry(RhinoDoc)
If the curve is referenced and not yet loaded, attempts to load the curve.
(Overrides GH_GeometricGooTLoadGeometry(RhinoDoc).)
Public methodMakeDeformable
Converts the local geometry into deformable nurbs curve geometry. This method will not destroy Reference data.
Public methodMorph (Overrides GH_GeometricGooTMorph(SpaceMorph).)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodScriptVariable (Overrides GH_GooTScriptVariable.)
Public methodToString
Format the curve using default grasshopper formatting logic.
(Overrides GH_GooTToString.)
Public methodTransform (Overrides GH_GeometricGooTTransform(Transform).)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also