Description:
If an analysis mode needs to modify display attributes, this is the place to do it. In particular, Style==Texture, then this function must be overridden.
Syntax:
protected virtual void SetUpDisplayAttributes(
RhinoObject obj,
DisplayPipelineAttributes attributes
)
RhinoObject obj,
DisplayPipelineAttributes attributes
)
protected
virtual
Parameters:
- obj
- Type: Rhino.DocObjects.RhinoObject
- The object for which to set up attributes.
- attributes
- Type: DisplayPipelineAttributes
- The linked attributes.
Returns:
Type: void
Remarks:
Shaded analysis modes that use texture mapping, like zebra and emap, override this function set the texture, diffuse_color, and EnableLighting parameter.