Description:

Quickly check a file for it's revision information. This function does not read the entire file, just what it needs to get revision information out

Syntax:
public static bool ReadRevisionHistory(
string path,
out string createdBy,
out string lastEditedBy,
out int revision,
out DateTime createdOn,
out DateTime lastEditedOn
)
Parameters:
  • path
  • Type: string
  • path to the 3dm file
  • createdBy
  • Type: string
  • original author of the file
  • lastEditedBy
  • Type: string
  • last person to edit the file
  • revision
  • Type: int
  • which revision this file is at
  • createdOn
  • Type: System.DateTime
  • date file was created (DateTime.MinValue if not set in file)
  • lastEditedOn
  • Type: System.DateTime
  • date file was last edited (DateTime.MinValue if not set in file)
Returns:
Type: bool
True on success
Available since:
5.6

/
/
/
ReadRevisionHistory

ReadRevisionHistory method

Class:  Rhino.FileIO.File3dm

Nothing found