Description:

Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.

Syntax:
public bool WriteWithLog(
string path,
File3dmWriteOptions options,
out string errorLog
)
Parameters:
  • path
  • Type: string
  • The file name to use for writing.
  • errorLog
  • Type: string
  • This argument will be filled by out reference.
Returns:
Type: bool
True if archive is written with no error. False if errors occur.
Available since:
6.0

Description:

Writes contents of this model to an openNURBS archive. If the model is not valid, then Write will refuse to write it.

Syntax:
public bool WriteWithLog(
string path,
int version,
out string errorLog
)
Parameters:
  • path
  • Type: string
  • The file name to use for writing.
  • version
  • Type: int
  • Version of the openNURBS archive to write. Must be [2; current version]. Rhino can read its current version, plus earlier file versions except 1. Use latest version when possible. Alternatively, 0 is a placeholder for the last valid version.
  • errorLog
  • Type: string
  • This argument will be filled by out reference.
Returns:
Type: bool
True if archive is written with no error. False if errors occur.
Available since:
5.0

WriteWithLog method

Class:  Rhino.FileIO.File3dm

Nothing found