Description:

Read a 3dm file from a specified location and log any archive reading errors.

Syntax:
public static File3dm ReadWithLog(
string path,
out string errorLog
)
Parameters:
  • path
  • Type: string
  • The file to read.
  • errorLog
  • Type: string
  • Any archive reading errors are logged here.
Returns:
Type: File3dm
New File3dm on success, None on error.
Available since:
5.0

Description:

Reads a 3dm file from a specified location.

Syntax:
public static File3dm ReadWithLog(
string path,
TableTypeFilter tableTypeFilterFilter,
ObjectTypeFilter objectTypeFilter,
out string errorLog
)
Parameters:
  • path
  • Type: string
  • The file to read.
  • tableTypeFilterFilter
  • Type: TableTypeFilter
  • If tableTypeFilterFilter is None, then everything in the archive is read. Otherwise tableTypeFilterFilter identifies what tables should be read.
  • objectTypeFilter
  • Type: ObjectTypeFilter
  • If objectTypeFilter is not None, then is a filter made by bitwise or-ing values to select which types of objects will be read from the model object table.
  • errorLog
  • Type: string
  • Any archive reading errors are logged here.
Returns:
Type: File3dm
new File3dm on success, None on error.
Available since:
5.9

ReadWithLog method

Class:  Rhino.FileIO.File3dm

Nothing found