Description:

Add an ngon for each group of connected coplanar faces.

Syntax:
public int AddPlanarNgons(
double planarTolerance,
int minimumNgonVertexCount,
int minimumNgonFaceCount,
bool allowHoles
)
Parameters:
  • planarTolerance
  • Type: double
  • 3d distance tolerance for coplanar test.
  • minimumNgonVertexCount
  • Type: int
  • Minimum number of vertices for an ngon.
  • minimumNgonFaceCount
  • Type: int
  • Minimum number of faces for an ngon.
  • allowHoles
  • Type: bool
  • Determines whether the ngon can have inner boundaries.
Returns:
Type: int
Number of ngons added to the mesh.
Available since:
6.0

Description:

Add an ngon for each group of connected coplanar faces.

Syntax:
public int AddPlanarNgons(
double planarTolerance
)
Parameters:
  • planarTolerance
  • Type: double
  • 3d distance tolerance for coplanar test.
Returns:
Type: int
Number of ngons added to the mesh.
Available since:
6.0

Nothing found