Description:

Determine if the ngon's boundary orientation matches that of the set of faces it is made from.

Syntax:
public int Orientation(
int index,
bool permitHoles
)
Parameters:
  • index
  • Type: int
  • Ngon index.
  • permitHoles
  • Type: bool
  • True if the ngon is permitted to have interior holes, False otherwise.
Returns:
Type: int
1: The ngon does not have holes, the ngon's faces are compatibly oriented, and the ngon's outer boundary orientation matches the faces' orientation. -1: The ngon does not have holes, the ngon's faces are compatibly oriented, and the ngon's outer boundary orientation is opposite the faces' orientation. 0: Otherwise.The ngon may be invalid, have holes, the ngon's faces may not be compatibly oriented, the ngons edges may not have a consistent orientation with respect to the faces, or some other issue.
Available since:
7.0

Nothing found