GH_StructureTDuplicateCastQ Method |
Create a duplicate of this structure in a different type.
Namespace:
Grasshopper.Kernel.Data
Assembly:
Grasshopper (in Grasshopper.dll)
Syntax public GH_Structure<Q> DuplicateCast<Q>(
GH_StructureTConversionDelegate<T, Q> conversion
)
where Q : IGH_Goo
Public Function DuplicateCast(Of Q As IGH_Goo) (
conversion As GH_StructureTConversionDelegate(Of T, Q)
) As GH_Structure(Of Q)
Parameters
- conversion
- Type: Grasshopper.Kernel.DataGH_StructureTConversionDelegateT, Q
Conversion delegate.
Type Parameters
- Q
- Type of conversion.
Return Value
Type:
GH_StructureQA duplicate of this structure with all valid casts.
See Also