Click or drag to resize

GH_StructureTLongestPathIndex Method

Finds the path in this structure with the most dimensions. In case of multiple equally long longest paths, the last one will be returned.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public int LongestPathIndex()

Return Value

Type: Int32
The index of the longest path or -1 if there are no paths.

Implements

IGH_StructureLongestPathIndex
See Also