Click or drag to resize

GH_StructureTPathIndex Method

Find the indices that surround the given path domain. Indices may be out of bounds.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void PathIndex(
	GH_Path path,
	ref int idx0,
	ref int idx1
)

Parameters

path
Type: Grasshopper.Kernel.DataGH_Path
Path to search for (it need not exist in the structure).
idx0
Type: SystemInt32
The index of the path itself or the first smaller path if the path is not defined.
idx1
Type: SystemInt32
The index of th path itself of the first larger path if the path is not defined.

Implements

IGH_StructurePathIndex(GH_Path, Int32, Int32)
See Also