Click or drag to resize

GH_StructureTInsert Method

Insert a data item into the specified branch in the structure. If the branch doesn't exist yet, it will be created.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void Insert(
	T data,
	GH_Path path,
	int index
)

Parameters

data
Type: T
Data to insert.
path
Type: Grasshopper.Kernel.DataGH_Path
Path of branch to insert into.
index
Type: SystemInt32
Insertion index.
See Also