Click or drag to resize

GH_Structure<T>.ExpandPath Method

Expand a path in this structure by appending an element.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void ExpandPath(
	GH_Path path,
	int element,
	GH_ExpandMode mode
)

Parameters

path
Type: Grasshopper.Kernel.Data.GH_Path
Path to expand, if the path doesn't exist, nothing will happen.
element
Type: System.Int32
Element to append to the path.
mode
Type: Grasshopper.Kernel.Data.GH_ExpandMode
Expansion mode.

Implements

IGH_Structure.ExpandPath(GH_Path, Int32, GH_ExpandMode)
See Also