Click or drag to resize

GH_RuleKind Enumeration

Represents all possible element types in a Path Pattern.

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_RuleKind
Members
  Member nameValueDescription
None0 Represents an invalid, default value.
AnyNumber1 Any single number
AnyNumbers2 Any (or no) collection of numbers
Number3 Single number
Group4 A collection of non-related integers.
Range5 A range of digits delimited by two extremes.
Sequence6 A collection of increasing non-related integers which repeat either indefinitely or up to a limit
Complex7 Represents a complex of multiple pattern types.
See Also