Description:

Orders a set of points so they will be connected in a "reasonable polyline" order. Also, removes points from the list if their common distance exceeds a specified threshold.

Syntax:
public static Point3d[] SortAndCullPointList(
IEnumerable<Point3d> points,
double minimumDistance
)
Parameters:
  • points
  • Type: System.Collections.Generic.IEnumerable<Point3d>
  • A list, an array or any enumerable of Point3d .
  • minimumDistance
  • Type: double
  • Minimum allowed distance among a pair of points. If points are closer than this, only one of them will be kept.
Returns:
Type: Point3d[]
The new array of sorted and culled points.
Available since:
5.0

/
/
/
SortAndCullPointList

SortAndCullPointList method

Class:  Rhino.Geometry.Point3d

Nothing found