Namespace: Rhino.UIDialogs: references
Dialogs()
KillSplash()
SetCustomColorDialog(EventHandler<GetColorEventArgs> handler)
ShowAboutDialog(bool forceSimpleDialog)
ShowCheckListBox(string title, string message,IList items, IList<bool> checkState)
ShowColorDialog(object parent,Color4f color, bool allowAlpha, NamedColorList namedColorList, OnColorChangedEvent colorCallback)
ShowColorDialog(object parent,Color4f color, bool allowAlpha, OnColorChangedEvent colorCallback)
ShowColorDialog(object parent,Color4f color, bool allowAlpha)
ShowColorDialog(Color4f color, bool allowAlpha)
ShowColorDialog(Color color, bool includeButtonColors, string dialogTitle, NamedColorList namedColorList)
ShowColorDialog(Color color, bool includeButtonColors, string dialogTitle)
ShowColorDialog(Color color)
ShowColorDialog(IWin32Window parent,Color4f color, bool allowAlpha)
ShowComboListBox(string title, string message,IList items)
ShowContextMenu(IEnumerable<string> items,Point screenPoint, IEnumerable<int> modes)
ShowEditBox(string title, string message, string defaultText, bool multiline, out string text)
ShowLayerMaterialDialog(RhinoDoc doc, IEnumerable<int> layerIndices)
ShowLineTypes(string title, string message, RhinoDoc doc,Guid selectedLineTypeId)
ShowLineTypes(string title, string message, RhinoDoc doc)
ShowListBox(string title, string message,IList items, object selectedItem)
ShowListBox(string title, string message,IList items)
ShowMessage(object parent, string message, string title, ShowMessageButton buttons, ShowMessageIcon icon, ShowMessageDefaultButton defaultButton, ShowMessageOptions options, ShowMessageMode mode)
ShowMessage(string message, string title, ShowMessageButton buttons, ShowMessageIcon icon)
ShowMessage(string message, string title)
ShowMessageBox(string message, string title,MessageBoxButtons buttons,MessageBoxIcon icon)
ShowMessageBox(string message, string title)
ShowMultiListBox(string title, string message, IList<string> items, IList<string> defaults)
ShowNumberBox(string title, string message, ref double number, double minimum, double maximum)
ShowNumberBox(string title, string message, ref double number)
ShowPrintWidths(string title, string message, double selectedWidth)
ShowPrintWidths(string title, string message)
ShowPropertyListBox(string title, string message, List<KeyValuePair<string, string>> items)
ShowPropertyListBox(string title, string message,IList items, IList<string> values)
ShowSelectLayerDialog(ref int layerIndex, string dialogTitle, bool showNewLayerButton, bool showSetCurrentButton, ref bool initialSetCurrentState)
ShowSelectLinetypeDialog(ref int linetypeIndex, bool displayByLayer)
ShowSelectMultipleLayersDialog(IEnumerable<int> defaultLayerIndices, string dialogTitle, bool showNewLayerButton, out int layerIndices)
ShowSemiModal(Form form)
ShowSunDialog(Sun sun)
ShowTextDialog(string message, string title)