Description:

Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.

Syntax:
public static ShowMessageResult ShowMessage(
object parent,
string message,
string title,
ShowMessageButton buttons,
ShowMessageIcon icon,
ShowMessageDefaultButton defaultButton,
ShowMessageOptions options,
ShowMessageMode mode
)
Parameters:
  • parent
  • Type: object
  • Parent window
  • message
  • Type: string
  • Message box text content.
  • title
  • Type: string
  • Message box title text.
Returns:
One of the ShowMessageBoxResult values.
Available since:
6.0

Description:

Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.

Syntax:
public static ShowMessageResult ShowMessage(
string message,
string title,
ShowMessageButton buttons,
ShowMessageIcon icon
)
Parameters:
  • message
  • Type: string
  • Message box text content.
  • title
  • Type: string
  • Message box title text.
Returns:
One of the ShowMessageBoxResult values.
Available since:
6.0

Description:

Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.

Syntax:
public static ShowMessageResult ShowMessage(
string message,
string title
)
Parameters:
  • message
  • Type: string
  • Message box text content.
  • title
  • Type: string
  • Message box title text.
Returns:
One of the ShowMessageBoxResult values.
Available since:
6.0

/
/
/
ShowMessage

ShowMessage method

Class:  Rhino.UI.Dialogs

Nothing found