menu
RhinoCommon API
search
search
V8
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Displays Rhino's property list box.
Syntax:
public static
string
ShowPropertyListBox(
string
title
,
string
message
,
List<KeyValuePair<string,
string>>
items
)
Parameters:
title
Type:
string
The dialog title.
message
Type:
string
The dialog message.
items
Type:
List<KeyValuePair<string, string>>
A list of key value pairs
Returns:
Type:
string
A list of property values if successful, None otherwise.
Available since:
8.0
Description:
Displays Rhino's property list box.
Syntax:
public static
string
ShowPropertyListBox(
string
title
,
string
message
,
IList
items
,
IList<string>
values
)
Parameters:
title
Type:
string
The dialog title.
message
Type:
string
The dialog message.
items
Type:
System.Collections.IList
A list of property names.
values
Type:
IList<string>
A list of property values.
Returns:
Type:
string
A list of property values if successful, None otherwise.
Available since:
5.0
home
/
Rhino.UI
/
Dialogs
/
ShowPropertyListBox
ShowPropertyListBox method
Class:
Rhino.UI.Dialogs
Nothing found