Description:

Displays Rhino's check list box.

Syntax:
public static bool ShowCheckListBox(
string title,
string message,
IList items,
IList<bool> checkState
)
Parameters:
  • title
  • Type: string
  • The dialog title.
  • message
  • Type: string
  • The dialog message.
  • items
  • Type: System.Collections.IList
  • A list of items to show.
  • checkState
  • Type: IList<bool>
  • A list of true/False boolean values.
Returns:
Type: bool
An array or boolean values determining if the user checked the corresponding box. On error, null.
Available since:
5.0

/
/
/
ShowCheckListBox

ShowCheckListBox method

Class:  Rhino.UI.Dialogs

Nothing found