Description:

Displays the standard modal color picker dialog for floating point colors.

Syntax:
public static bool ShowColorDialog(
object parent,
ref Color4f color,
bool allowAlpha,
NamedColorList namedColorList,
OnColorChangedEvent colorCallback
)
Parameters:
  • parent
  • Type: object
  • Parent window for this dialog, should always pass this if calling from a form or user control.
  • color
  • Type: Display.Color4f
  • The initial color to set the picker to and also accepts the user's choice.
  • allowAlpha
  • Type: bool
  • Specifies if the color picker should allow changes to the alpha channel or not.
  • namedColorList
  • Type: NamedColorList
  • If not None and contains at least one named color this list will replace the standard Rhino Color list displayed by the rhino color dialog.
  • colorCallback
  • Type: OnColorChangedEvent
  • May be optionally passed to ShowColorDialog and will get called when the color value changes in the color dialog.
Returns:
Type: bool
True if a color was picked, False if the user canceled the picker dialog.
Available since:
6.0

Description:

Displays the standard modal color picker dialog for floating point colors.

Syntax:
public static bool ShowColorDialog(
object parent,
ref Color4f color,
bool allowAlpha,
OnColorChangedEvent colorCallback
)
Parameters:
  • parent
  • Type: object
  • Parent window for this dialog, should always pass this if calling from a form or user control.
  • color
  • Type: Display.Color4f
  • The initial color to set the picker to and also accepts the user's choice.
  • allowAlpha
  • Type: bool
  • Specifies if the color picker should allow changes to the alpha channel or not.
  • colorCallback
  • Type: OnColorChangedEvent
  • May be optionally passed to ShowColorDialog and will get called when the color value changes in the color dialog.
Returns:
Type: bool
True if a color was picked, False if the user canceled the picker dialog.
Available since:
6.0

Description:

Displays the standard modal color picker dialog for floating point colors.

Syntax:
public static bool ShowColorDialog(
object parent,
ref Color4f color,
bool allowAlpha
)
Parameters:
  • parent
  • Type: object
  • Parent window for this dialog, should always pass this if calling from a form or user control.
  • color
  • Type: Display.Color4f
  • The initial color to set the picker to and also accepts the user's choice.
  • allowAlpha
  • Type: bool
  • Specifies if the color picker should allow changes to the alpha channel or not.
Returns:
Type: bool
True if a color was picked, False if the user canceled the picker dialog.
Available since:
6.0

Description:

Displays the standard modal color picker dialog for floating point colors.

Syntax:
public static bool ShowColorDialog(
ref Color4f color,
bool allowAlpha
)
Parameters:
  • color
  • Type: Display.Color4f
  • The initial color to set the picker to and also accepts the user's choice.
  • allowAlpha
  • Type: bool
  • Specifies if the color picker should allow changes to the alpha channel or not.
Returns:
Type: bool
True if a color was picked, False if the user canceled the picker dialog.
Available since:
5.0

Description:

Display Rhino's color selection dialog.

Syntax:
public static bool ShowColorDialog(
ref Color color,
bool includeButtonColors,
string dialogTitle,
NamedColorList namedColorList
)
Parameters:
  • color
  • Type: System.Drawing.Color
  • [in/out] Default color for dialog, and will receive new color if function returns true.
  • includeButtonColors
  • Type: bool
  • Display button face and text options at top of named color list.
  • dialogTitle
  • Type: string
  • The title of the dialog.
  • namedColorList
  • Type: NamedColorList
  • If not None and contains one or more named colors the Rhino color dialog named color list will be replaces with this list.
Returns:
Type: bool
True if the color changed. False if the color has not changed or the user pressed cancel.
Available since:
5.0

Description:

Display Rhino's color selection dialog.

Syntax:
public static bool ShowColorDialog(
ref Color color,
bool includeButtonColors,
string dialogTitle
)
Parameters:
  • color
  • Type: System.Drawing.Color
  • [in/out] Default color for dialog, and will receive new color if function returns true.
  • includeButtonColors
  • Type: bool
  • Display button face and text options at top of named color list.
  • dialogTitle
  • Type: string
  • The title of the dialog.
Returns:
Type: bool
True if the color changed. False if the color has not changed or the user pressed cancel.
Available since:
5.0

Description:

Display Rhino's color selection dialog.

Syntax:
public static bool ShowColorDialog(
ref Color color
)
Parameters:
  • color
  • Type: System.Drawing.Color
  • [in/out] Default color for dialog, and will receive new color if function returns true.
Returns:
Type: bool
True if the color changed. False if the color has not changed or the user pressed cancel.
Available since:
5.0

Description:

Displays the standard modal color picker dialog for floating point colors.

Syntax:
public static bool ShowColorDialog(
IWin32Window parent,
ref Color4f color,
bool allowAlpha
)
deprecated in 6.0
obsolete: Use ShowColorDialog
Parameters:
  • parent
  • Type: System.Windows.Forms.IWin32Window
  • Parent window for this dialog, should always pass this if calling from a form or user control.
  • color
  • Type: Display.Color4f
  • The initial color to set the picker to and also accepts the user's choice.
  • allowAlpha
  • Type: bool
  • Specifies if the color picker should allow changes to the alpha channel or not.
Returns:
Type: bool
True if a color was picked, False if the user canceled the picker dialog.
Available since:
5.0

/
/
/
ShowColorDialog

ShowColorDialog method

Class:  Rhino.UI.Dialogs

Nothing found