Click or drag to resize

GH_LibraryLicense Enumeration

Enumerates the possible library types for GHA assemblies.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_LibraryLicense
Members
  Member nameValueDescription
unset0 Unset library type. You should not return this value.
expired1 The license for this library has expired and it can no longer be used.
alpha2 This library is an Alpha release.
beta3 This library is a Beta release.
free4 This library is freeware.
opensource5 This library is distributed under an open source license.
trial6 This library is running in Trial mode.
commercial7 This library is running under a Commercial license.
educational8 This library is running under an Educational license.
developer9 This library is running under a Developer license.
reseller10 This library is running under a Reseller license.
other11 Undefined library type.
See Also