Click or drag to resize

GH_ParamKind Enumeration

Enumerates the different guises of parameter

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public enum GH_ParamKind
Members
  Member nameValueDescription
unknown0 Unknown, when this happens, something went wrong. Most likely it is due to someone deriving from GH_Param and not setting the kind.
floating1 Parameter is top-level.
input2 Parameter is tied to an owner component as an input.
output3 Parameter is tied to an owner component as an output.
See Also