Click or drag to resize

GH_DocumentObjectMenu_AppendColourPicker Method

Add a colour picker to a menu.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static GH_ColourPicker Menu_AppendColourPicker(
	ToolStripDropDown menu,
	Color colour,
	GH_DocumentObjectColourEventHandler colourChanged
)

Parameters

menu
Type: System.Windows.FormsToolStripDropDown
Menu to add to.
colour
Type: System.DrawingColor
Default colour.
colourChanged
Type: Grasshopper.KernelGH_DocumentObjectColourEventHandler
Handler for Colour picker changed events.

Return Value

Type: GH_ColourPicker
Menu item representing the colour picker.
See Also