Click or drag to resize

GH_DocumentObjectMenu_AppendSeparator Method

Utility function for appending separators to a menu dropdown. If the dropdown is empty or if it already has a separator at the bottom, nothing will happen.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static ToolStripSeparator Menu_AppendSeparator(
	ToolStrip menu
)

Parameters

menu
Type: System.Windows.FormsToolStrip
Menu to append separator to.

Return Value

Type: ToolStripSeparator
The appended separator or null if no separator was appended.
See Also