Click or drag to resize

GH_DocumentObjectAppendMenuItems Method

This function is called when a context menu is about to be displayed. Override it to set custom items.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public virtual bool AppendMenuItems(
	ToolStripDropDown menu
)

Parameters

menu
Type: System.Windows.FormsToolStripDropDown
Menu object to populate.

Return Value

Type: Boolean
If true, the menu will be displayed, if false the menu will be supressed.

Implements

IGH_DocumentObjectAppendMenuItems(ToolStripDropDown)
See Also