Click or drag to resize

GH_GooProxyT Class

Abstract base implementation of IGH_GooProxy
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooProxyT
    More...

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_GooProxy<T> : IGH_GooProxy
where T : IGH_Goo

Type Parameters

T

The GH_GooProxyT type exposes the following members.

Constructors
  NameDescription
Protected methodGH_GooProxyT
Initializes a new instance of the GH_GooProxyT class
Top
Properties
  NameDescription
Public propertyTypeDescription
Public propertyTypeName
Public propertyValid
Gets a value indicating whether this proxy represents valid data.
Top
Methods
  NameDescription
Public methodConstruct
Override this method to supply a custom UI during proxy construction.
Public methodFormatInstance
Returns a String description of the current value.
Public methodFromString
If IsParsable(), then attempts to convert the string to a generic type value
Public methodMutateString
Munge a string to remove obvious errors on account of the user.
Protected methodNumberToString
Protected methodStringToNumber
Public methodToString (Overrides ObjectToString.)
Top
See Also
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooProxyT
    Grasshopper.Kernel.TypesGH_BoxGH_BoxProxy
    Grasshopper.Kernel.TypesGH_BrepGH_BrepProxy
    Grasshopper.Kernel.TypesGH_CircleGH_CircleProxy
    Grasshopper.Kernel.TypesGH_CurveGH_CurveProxy
    Grasshopper.Kernel.TypesGH_GeometryGroupGH_GeometryGroupProxy
    Grasshopper.Kernel.TypesGH_Interval2DGH_Interval2DProxy
    Grasshopper.Kernel.TypesGH_LineGH_LineProxy
    Grasshopper.Kernel.TypesGH_MaterialGH_Material_Proxy
    Grasshopper.Kernel.TypesGH_MeshGH_MeshProxy
    Grasshopper.Kernel.TypesGH_MeshFaceGH_MeshFaceProxy
    Grasshopper.Kernel.TypesGH_MeshingParametersRhMesherSettings_Proxy
    Grasshopper.Kernel.TypesGH_PlaneGH_PlaneProxy
    Grasshopper.Kernel.TypesGH_PointGH_PointProxy
    Grasshopper.Kernel.TypesGH_RectangleGH_RectangleProxy
    Grasshopper.Kernel.TypesGH_SurfaceGH_SurfaceProxy
    Grasshopper.Kernel.TypesGH_VectorGH_VectorProxy