Description:

Adds a command line option.

Syntax:
public int AddOption(
LocalizeStringPair optionName,
LocalizeStringPair optionValue,
bool hiddenOption
)
Parameters:
  • optionName
  • Type: LocalizeStringPair
  • Must only consist of letters and numbers (no characters list periods, spaces, or dashes).
  • hiddenOption
  • Type: bool
  • If true, the option is not displayed on the command line and the full option name must be typed in order to activate the option.
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
6.9

Description:

Adds a command line option.

Syntax:
public int AddOption(
LocalizeStringPair optionName,
LocalizeStringPair optionValue
)
Parameters:
  • optionName
  • Type: LocalizeStringPair
  • Must only consist of letters and numbers (no characters list periods, spaces, or dashes).
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
5.0

Description:

Adds a command line option.

Syntax:
public int AddOption(
LocalizeStringPair optionName
)
Parameters:
  • optionName
  • Type: LocalizeStringPair
  • Must only consist of letters and numbers (no characters list periods, spaces, or dashes).
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
5.0

Description:

Adds a command line option.

Syntax:
public int AddOption(
string englishOption,
string englishOptionValue,
bool hiddenOption
)
Parameters:
  • englishOption
  • Type: string
  • Must only consist of letters and numbers (no characters list periods, spaces, or dashes).
  • englishOptionValue
  • Type: string
  • The option value in English, visualized after an equality sign.
  • hiddenOption
  • Type: bool
  • If true, the option is not displayed on the command line and the full option name must be typed in order to activate the option.
Returns:
Type: int
Option index value (>0) or 0 if option cannot be added.
Available since:
6.9

Description:

Adds a command line option.

Syntax:
public int AddOption(
string englishOption,
string englishOptionValue
)
Parameters:
  • englishOption
  • Type: string
  • Must only consist of letters and numbers (no characters list periods, spaces, or dashes).
  • englishOptionValue
  • Type: string
  • The option value in English, visualized after an equality sign.
Returns:
Type: int
Option index value (>0) or 0 if option cannot be added.
Available since:
5.0

Description:

Adds a command line option.

Syntax:
public int AddOption(
string englishOption
)
Parameters:
  • englishOption
  • Type: string
  • Must only consist of letters and numbers (no characters list periods, spaces, or dashes).
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
5.0

Nothing found