Description:

Adds a choice of enumerated values as list option. Allows to include only some enumerated values.

Syntax:
public int AddOptionEnumList(
string englishOptionName,
T defaultValue,
T[] include
)
Parameters:
  • englishOptionName
  • Type: string
  • The name of the option
  • defaultValue
  • Type: T
  • The default value
  • include
  • Type: T[]
  • An array of enumerated values to use. This argument can also be null; in this case, the whole enumerated is used.
Returns:
Type: int
Option index
Available since:
6.0

Description:

Adds a choice of enumerated values as list option

Syntax:
public int AddOptionEnumList(
string englishOptionName,
T defaultValue
)
Parameters:
  • englishOptionName
  • Type: string
  • The name of the option
  • defaultValue
  • Type: T
  • The default value
Returns:
Type: int
Option index
Available since:
5.4

AddOptionEnumList method

Class:  Rhino.Input.Custom.GetBaseClass

Nothing found