Description:

Add a command line option to get colors and automatically save the value.

Syntax:
public int AddOptionColor(
LocalizeStringPair optionName,
ref OptionColor colorValue,
string prompt
)
Parameters:
  • prompt
  • Type: string
  • option prompt shown if the user selects this option
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
5.0

Description:

Add a command line option to get colors and automatically save the value.

Syntax:
public int AddOptionColor(
LocalizeStringPair optionName,
ref OptionColor colorValue
)
Parameters:
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
5.0

Description:

Add a command line option to get colors and automatically save the value.

Syntax:
public int AddOptionColor(
string englishName,
ref OptionColor colorValue,
string prompt
)
Parameters:
  • englishName
  • Type: string
  • option description
  • prompt
  • Type: string
  • The command prompt will show this during picking.
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
5.0

Description:

Add a command line option to get colors and automatically save the value.

Syntax:
public int AddOptionColor(
string englishName,
ref OptionColor colorValue
)
Parameters:
  • englishName
  • Type: string
  • option description
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
5.0

AddOptionColor method

Class:  Rhino.Input.Custom.GetBaseClass

Nothing found