Description:

Sets a point as default value that will be returned if the user presses the ENTER key during the get.

Syntax:
public void SetDefaultPoint(
Point3d point
)
Parameters:
  • point
  • Type: Point3d
  • value for default point.
Returns:
Type: void
Remarks:
Calling SetDefaultPoint will automatically handle setting the command prompt default and reacting to the user pressing ENTER. If the user presses enter to accept the default point, GetResult.Point is returned and RhinoGet.GotDefault() will return true. Calling SetDefaultPoint will clear any previous calls to SetDefaultString or SetDefaultNumber.
Available since:
5.0

SetDefaultPoint method

Class:  Rhino.Input.Custom.GetBaseClass

Nothing found