Description:

Control the availability of transparent commands during the get.

Syntax:
public void EnableTransparentCommands(
bool enable
)
Parameters:
  • enable
  • Type: bool
  • If true, then transparent commands can be run during the get. If false, then transparent commands cannot be run during the get.
Returns:
Type: void
Remarks:
Some Rhino commands are "transparent" and can be run inside of other commands. Examples of transparent commands include the view manipulation commands like ZoomExtents, Top, etc., and the selection commands like SelAll, SelPoint, etc. By default transparent commands can be run during any get. If you want to disable this feature, then call EnableTransparentCommands(false) before calling GetString, GetPoint, GetObject, etc.
Available since:
5.0

/
/
/
EnableTransparentCommands

EnableTransparentCommands method

Class:  Rhino.Input.Custom.GetBaseClass

Nothing found