Click or drag to resize

GH_GraphicsUtilCreateColourIcon Method

Create a colour swatch icon.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static Bitmap CreateColourIcon(
	int width,
	int height,
	Color colour
)

Parameters

width
Type: SystemInt32
Width of icon.
height
Type: SystemInt32
Height of icon.
colour
Type: System.DrawingColor
Colour for swatch, if colour contains an alpha component, you should draw an alpha-grid behind the icon.

Return Value

Type: Bitmap
A bitmap with the requested icon colour.
See Also