Click or drag to resize

GH_GraphicsUtilScaleColour Method

Multiply the channels of a colour construct with a fixed factor.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static Color ScaleColour(
	Color col,
	double factor
)

Parameters

col
Type: System.DrawingColor
The colour to mutate
factor
Type: SystemDouble
An adjustment factor.

Return Value

Type: Color
The scaled colour.
Remarks
The alpha channel of the colour is not mutated.
See Also