Click or drag to resize

GH_GraphicsUtilIsPointInEllipse Method

Test whether a point is inside or outside an ellipse.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static bool IsPointInEllipse(
	RectangleF ellipse,
	PointF point
)

Parameters

ellipse
Type: System.DrawingRectangleF
Rectangle describing ellipse.
point
Type: System.DrawingPointF
Point to test for inclusion.

Return Value

Type: Boolean
True if the point is in or on the ellipse.
See Also