Click or drag to resize

GH_GraphicsUtilRenderIcon Method

Render an icon into a frame. The icon is positioned in the center and will be drawn at its own size multiplied by the system UiScale, provided it doesn't exceed the frame.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void RenderIcon(
	Graphics graphics,
	RectangleF frame,
	Image icon
)

Parameters

graphics
Type: System.DrawingGraphics
Graphics object to draw with.
frame
Type: System.DrawingRectangleF
Limiting frame.
icon
Type: System.DrawingImage
Icon to draw.
See Also