Click or drag to resize

GH_GraphicsUtilRenderVerticalString Method

Render vertical text (rotated 90 degrees counter-clockwise) within a rectangle.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void RenderVerticalString(
	Graphics g,
	string text,
	Font font,
	Color colour,
	RectangleF rec,
	StringFormat format
)

Parameters

g
Type: System.DrawingGraphics
Graphics object to draw with.
text
Type: SystemString
Text to render.
font
Type: System.DrawingFont
Font to render with.
colour
Type: System.DrawingColor
Colour of text content.
rec
Type: System.DrawingRectangleF
format
Type: System.DrawingStringFormat
Formatting flags.
See Also