Click or drag to resize

GH_GraphicsUtilFadeColour Method

Fade a colour to transparency by linearly blending a parameter between extremes.

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static Color FadeColour(
	double t0,
	double t1,
	double t,
	Color col
)

Parameters

t0
Type: SystemDouble
First extreme. (represents transparency)
t1
Type: SystemDouble
Second extreme. (represent unaltered colour)
t
Type: SystemDouble
Blending factor between t0 and t1.
col
Type: System.DrawingColor
Colour to fade.

Return Value

Type: Color
The colour adjusted for blending.
See Also