Click or drag to resize

GH_MemoryBitmapFilter_Tint Method

Colorize the image using Hue and Saturation from a base colour.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public void Filter_Tint(
	Color tint,
	double lum_factor,
	double sat_factor
)

Parameters

tint
Type: System.DrawingColor
Colour of colorize operation.
lum_factor
Type: SystemDouble
Luminance blend factor. 0.0 equals no luminance adjustment, 1.0 equals complete luminance adjustment.
sat_factor
Type: SystemDouble
Saturation blend factor. 0.0 equals no saturation adjustment, 1.0 equals complete saturation adjustment.
See Also