Description:

Adds a line object to Rhino.

Syntax:
public Guid AddLine(
Line line,
ObjectAttributes attributes
)
Parameters:
  • line
  • Type: Line
  • A line.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a line object to Rhino.

Syntax:
public Guid AddLine(
Line line
)
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a line object to Rhino.

Syntax:
public Guid AddLine(
Point3d from,
Point3d to,
ObjectAttributes attributes
)
Parameters:
  • from
  • Type: Point3d
  • The start point of the line.
  • to
  • Type: Point3d
  • The end point of the line.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a line object to Rhino.

Syntax:
public Guid AddLine(
Point3d from,
Point3d to
)
Parameters:
  • from
  • Type: Point3d
  • A line start point.
Returns:
Type: Guid
A unique identifier of new rhino object.
Available since:
5.0

Nothing found