Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
Text3d text3d,
ObjectAttributes attributes
)
Parameters:
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
Text3d text3d
)
Parameters:
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic,
ObjectAttributes attributes
)
Parameters:
  • plane
  • Type: Plane
  • Plane of text.
  • height
  • Type: double
  • Height of text.
  • fontName
  • Type: string
  • Name of FontFace.
  • bold
  • Type: bool
  • Bold flag.
  • italic
  • Type: bool
  • Italic flag.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic,
TextJustification justification,
ObjectAttributes attributes
)
Parameters:
  • plane
  • Type: Plane
  • Plane of text.
  • height
  • Type: double
  • Height of text.
  • fontName
  • Type: string
  • Name of FontFace.
  • bold
  • Type: bool
  • Bold flag.
  • italic
  • Type: bool
  • Italic flag.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic,
TextJustification justification
)
Parameters:
  • plane
  • Type: Plane
  • Plane of text.
  • height
  • Type: double
  • Height of text.
  • fontName
  • Type: string
  • Name of FontFace.
  • bold
  • Type: bool
  • Bold flag.
  • italic
  • Type: bool
  • Italic flag.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Description:

Adds an annotation text object to the document.

Syntax:
public Guid AddText(
string text,
Plane plane,
double height,
string fontName,
bool bold,
bool italic
)
Parameters:
  • plane
  • Type: Plane
  • Plane of text.
  • height
  • Type: double
  • Height of text.
  • fontName
  • Type: string
  • Name of FontFace.
  • bold
  • Type: bool
  • Bold flag.
  • italic
  • Type: bool
  • Italic flag.
Returns:
Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
Available since:
5.0

Nothing found