Description:

Adds a point object to the table.

Syntax:
public Guid AddPoint(
double x,
double y,
double z
)
Parameters:
  • x
  • Type: double
  • X component of point coordinate.
  • y
  • Type: double
  • Y component of point coordinate.
  • z
  • Type: double
  • Z component of point coordinate.
Returns:
Type: Guid
id of new object.
Available since:
5.0

Description:

Adds a point object to the document.

Syntax:
public Guid AddPoint(
Point3d point,
ObjectAttributes attributes
)
Parameters:
  • point
  • Type: Point3d
  • A location for point.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a point object to the table.

Syntax:
public Guid AddPoint(
Point3d point
)
Parameters:
  • point
  • Type: Point3d
  • A location for point.
Returns:
Type: Guid
Id of new object.
Available since:
5.0

Description:

Adds a point object to the document.

Syntax:
public Guid AddPoint(
Point3f point,
ObjectAttributes attributes
)
Parameters:
  • point
  • Type: Point3f
  • location of point.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Description:

Adds a point object to the document.

Syntax:
public Guid AddPoint(
Point3f point
)
Parameters:
  • point
  • Type: Point3f
  • location of point.
Returns:
Type: Guid
A unique identifier for the object.
Available since:
5.0

Nothing found