Description:

Gets a rectangle in view window coordinates.

Syntax:
public static Result Get2dRectangle(
bool solidPen,
out Rectangle rectangle,
out RhinoView rectView
)
Parameters:
  • solidPen
  • Type: bool
  • If true, a solid pen is used for drawing while the user selects a rectangle. If false, a dotted pen is used for drawing while the user selects a rectangle.
  • rectangle
  • Type: Rectangle
  • user selected rectangle in window coordinates.
  • rectView
  • Type: RhinoView
  • view that the user selected the window in.
Returns:
Type: Result
Success or Cancel.
Available since:
5.0

/
/
/
Get2dRectangle

Get2dRectangle method

Class:  Rhino.Input.RhinoGet

Nothing found